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1. Database Installation 

 

1.1. MSSQL Server 

1) Put MS-SQL 2000 CD into the CD-ROM and select “SQL Server 2000 Components” as shown below. 

 

 

 

2) Select “Install Database Server” 
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3) Click “Next>” button. 

 

 

4) Select “Local Computer” and click “Next>” button. 
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5) Select “Create a new instance of SQL Server, or install Client Tools” and clcik “Next>” button. 

 

 

6) Enter “Name” and “Company”.  Clcik “Next>” button. 
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7) Click “Yes” button. 

 

 

8) Select “Server and Client Tools” and click “Next>” button. 
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9) Check “Default” and click “Next>” button. 

 

 

10) Select “Typical” and click “Next>” button. 
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11) Select “Use a Domain User account” and remove “Username” and “Password” as shown below.  

Click “Next>” button. 

 

 

12) Select “Mixed Mode” and click “Next>” button. 
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13) Click “Next>” button to begin installation. 
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14) Click “Finish” button to complete setup. 
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2. VPMS Server 

2.1. Install JRE (Java Runtime Environment) 

JRE(Java Runtime Environment) installation is required to activate MBMS server. If JRE has been 

already installed, you wouldn’t need to install. 

You can check this by executing ‘java’ command on DOS mode.  

You can download and intall JRE through Java web(http://java.sun.com). 

Installation procedure is as below. 

 

1) Visit Java web(http://java.sun.com). 

2) Click the latest version(J2SE_1.4.2 SDK) on Popular Downloads category at the right section of 

the page. 
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3) Select J2SE v1.4.2_05 JRE or the latest version of JRE.  
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4) Accept agreement and proceed next. 
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5) Download offline version of JRE windows Platform and install. 
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6) After executing downloaded file and accept the terms in the license agreement. 

 

 

 

 

7) Select Typical mode. 
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8) Installation is being proceeded. 

 

 

 

 

9) Click Finish tab and finish JRE installation. 
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2.2. VPMS Server Installation 

Install VPMS Server on Server PC. 

 

 

1) Execute VPMS Server installation file and click Next. 
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2) Select “ I accept the terms in the license agreement” and click “next>” button. 

 

 

 

 

3) Enter User Name, Organization and Serial number. Then, click “Next>” button. 
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4) Select the path to install the program. 

 

 

 

 

5) Clcik “Install” button. 

 

 

 



VPMS Installation Manual 

          - 20 - 

 

6) Install the program. 

 

 

7) Click “Finish” button to complete program installation. 

 

 

8) The program is regitered under [Start]> [Programs]> [Addpac APMS]> [VPMS Server]. 
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2.3. VPMS Database Configuration 

2.3.1. MSSQL Database Configuration 
 

Database configuration is script execution process, which is setting the basic environment of 

MSSQL DB at VPMS Server.  

 

1) Select  [Start]> [Programs]> [Microsoft SQL Server]> [Service Manager] from Windows. 

2) Click “Start/Continue” button to start SQL service. 

 

 

3) Select [Start]> [Programs]> [Microsoft SQL Server]> [Enterprise Manager], to creat   Database and 

an account. 
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4) Select Tools > SQL Query Analyzer in Enterprise Manager Menu. 

 

 

5) Select [File]> [Open] from SQL Query Analyzer menu or click “Load SQL Script” button to call 

‘ap_vpms.sql’ script file 

 

★ “ap_vpms.sql” is under same path where Server program is installed. 

( “c:\Program Files\AddPac\VPMS_Server\Initial_data\ap_vpms.sql” ) 
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6) “ap_vpms.sql” is called. 

 
 

 

7) Click “Execute Query” or select [Query]> [Execute] from the menu to execute the script.  Then the 

table and basic data is created. 
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2.3.2. MSSQL Agent Configuration 
 

Agent Configuration is needed to improve processing performance by deleting outdated data. 

 

1) Execute Windows Start>Setting>Control Panels>Administrative Tools->Services. 

2) Run SQLSERVERAGENT. 

3) Set Automatic as Startup Type in Properties ans Start. 
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4) Run Start>Programs>Microsoft SQL Server>Enterprise Manager to register Agent detail. 
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5) Choose Tools > SQL Query Analyzer in Enterprise Manager Menu. 

 

 

6) Choose File>Open in SQL Query Analyzer menu or Click Load SQL Script tab to open  

‘ap_vpms_history_remove’ script file 

 

★ ap_vpms.sql file is under same path where Server program is installed. 

( “c:\Program Files\AddPac\VPMS_Server\Initial_data\ap_vpms_history_remove.sql” ) 
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7) Choose ap_vpms_history_remove.sql and open. 
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8) Set value for operation starting date (@START_DATE) ex: 20050513) and Click Execute 

Query or Choose Query>Execute to run the script for appending new Agent operation. 

 

9) User can check the appended Agent operation in Enterprise Manager->Management->SQL 

Server Agent -> Jobs and Start Operation. 
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2.4. Server Database Configuring 

 

1) Environment setting file (“db.properties”) 

- “c:\Program files\Addpac\VPMS Server\db.properties” 

 

 

 

2) Environment setting 

- Information such as Driver, IP address & port, log-in account is registered inn the 

environment setting file.  

- Following example is for MSSQL setting. Highlighted part can be modified and 

database server IP address can be registered. 

 

 

 

 
drivers=com.inet.pool.PoolDriver 
                                                                            
logfile=/dbPool.log 
                                                                           
mydb.url=jdbc:inetpool:inetdae7:172.16.31.2:1433?database=apems 
mydb.maxconn=50 
mydb.user=apems 
mydb.password=apems 

[Config] MSSQL “db.properties” file setting 
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3. VPMS Client 

3.1. VPMS Client Installation 

VPMS Client is installed at Client PC and it can be installed at more than one PC. 

 

 

1) Run VPMS client installation file and click Next. 

 

 
 

 

 



VPMS Installation Manual 

          - 31 - 

 

2) Select “I accept the terms in thelicense agreement” abd click “Next>” button. 

 

 
 

3) Enter “User Name”, “Organization” and assigned “Serial Number”.  Click “Next>” button. 
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4) Select folder where setup will install files. 

 

 
 

 

5) Click Install to begin the installation. 

 

 
 



VPMS Installation Manual 

          - 33 - 

6) Install VPMS client. 

 

 
 

7) Click “Finish” button to complete installation. 

 

 
 

8) The program is registered at [Start]> [Programs]> [Addpac APMS]> [VPMS Client]. 

 



VPMS Installation Manual 

          - 34 - 

 

3.2. Client Database Setting 

 

1) When you run Client program in the first time Client, database setting window will come 

up automatically. You can configure the setting by running “server.udl” in the program 

derectory. 

 

 

 

 

 

2) With firsttime VPMS client running, Server.udl not found window pops up, click OK to 

proceed. 
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3) Setting for connection to database can be configured in Data Link Properties window. 
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4) Select Provider tab and choose SQL server for data provider and click Next button. 
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5) Enter Server name or Server IP address. Set User name(apems), Password(apems)

를and choose Database(apems). When the setting is completed, proceed 

Testconnection to confirm if setting is applied alright.  

 

 

 

 

6) Click Test Connection to confirm if MSSQL DB setting has no problems. 

 

7) Click OK to save the setting and run vpms client again. 
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4. VPMS Program Running 

4.1. Server Program Execution 

1) Select [Start]> [Programs]> [AddPac]> [VPMS Server]> [VPMS_Server]. 

 

2) Program is executed.  
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4.2. Client Program Execution 

 

1) Select [Start]> [Programs]> [AddPac]> [VPMS Client]> [VoIP PnP Management System 1.00“]. 

 

 

 

 

 

2) The Login dialog box of VPMS program is appears.  The defualut login information is (Operator 

id : root, password : router).   

 

(The login information can be added, deleted and modified at the program.  So chenage the default 

Operator ID.) 
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3) After the login process, the below VPMS Client main page is diaplyed. 
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4.3. Tera Term Installation 

Tera Term is needed for gateway debugging.  

If Tera Term is not installed, you won’ t use VPMS Telnet functions. 

 

1) Teraterm program can be downloaded from  

http://hp.vector.co.jp/authors/VA002416/teraterm.html . 

 
 

2) After downloading Teraterm, unzip “ttermp23.zip”. 

3) Run Setup.exe. 
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4) Choose English. 

 

 

5) Select Continue. 
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6) Select the path where TeraTerm will be installed.  

 

 

7) TeraTerm Installation is completed.  
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5. Auto Upgrade Server Installation 

5.1. Configure Web Service (IIS) 

▪ This example of Auto upgrade server installation is based on Windows 2000 Server OS. 

 

1) At first, confirm that Web service is already running on target Windows Server. 
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▪ Run web browser to connect http://localhost/localstart.asp, if you saw the upper screen, web service 

could be being operated normally. 

▪ When web service is not running on target server, confirm that the IIS service is running 

on the server shown as below. 

 

 

2) Default directory of Web Server is “C:\Inetpub\wwwroot\”. 

▪ If you want to modify webserver default directory, you can modify it at internet information 

service(Start > Programs > Adminstrative Tools > Internet Information Services). 

▪ Choose Properties to open pull down menu at Default Web Site. 
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▪ Set the path to modify Home Directory. 

 
 

 

5.2. Configure FTP Server (IIS)  

▪ FTP server could be running well if you installed Windows2000 server. 

▪ Generate new log-in account for FTP service. 

 

1) To add a new user account, execute (Start > Programs > Administrative Tools > Computer 

Management). 
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2) Select System Tools > Local Users and Groups > Users to open pull down menu and select New 

User. 

 

 

3) Register new user. 
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4) Start FTP service (Start > Programs > Administrative Tools > Internet Information Services). 

 

 

 

5) Select New > Site by clicking mouse right button at Default FTP Site. 
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6) FTP Site Creation Wizard will pop-up. (next) 

 

 

 

7) Set description. (next) 
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8) Set auto upgrade server IP address and port(21). (next) 

 

 

 

9) Set Home Directory as same as Web server’s Home Directory. 
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10) Set access permission to allow read and write. (next) 

 

 

 

11) Finish FTP site creation wizard. (Finish) 
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12) For download file by FTP, set access permission of Home Directory. Explore to Properties in 

Home directory. 

 
 

13) Add “root” user account in Properties Security tab. 
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14) Add “root” user account and set permissions as below. 

 

 

15) If the configuration is completed, you can test ftp connection and file transfer with root account. 

 

 

 


